NetCommons2再び PHP5.4でのインストール

一切外部に公開しないサイトをつくるのに、汎用データベースモジュールのあるNetCommonsが一番楽かも

とUbuntu13.04マシンにて、インストールを始めようとしたが、現行の2.4.1.0はPHP5.4に対応しておらず、エラーの山が表示される。
#Ubuntu13.04ではPHP5.4なわけでPHP5.3.25あたりを野良ビルドするのも面倒(^^;;

ぐぐってみると、暫定的な対応をしているらしく、コードを追う余裕もスキルもないため、Githubからdevelop版をダウンロードさせてもらう。感謝。

とりあえず、ErrorもWarningも出ずインストールは無事に終わった。

ローカルで自分しかみないやつなので今回はこれでいいだろう。


2013/09/19現在は、公式サイトでVer2.4.2.0という上の対策済みのバージョンがダウンロードできる。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です