さくらでRast-0.3.1(失敗)

Rast-0.2.0関連でビルドしたものを全部アンインストールして、再度

追加ビルドしたもの

  • apr-1.2.2
  • apr-util-1.2.2
  • file-4.16
  • db-4.3.29

configure

% setenv LD_RUN_PATH $PREFIX_DIR/lib
% cd rast-0.3.1
% ./configure --prefix=$PREFIX_DIR 
              --with-apr-config=$PREFIX_DIR/bin/apr-1-config 
              --with-apu-config=$PREFIX_DIR/bin/apu-1-config 
              --with-db-includes="-I$PREFIX_DIR/include" 
              --with-db-libs="-L$PREFIX_DIR/lib -ldb-4.3"

file-4.16を入れたので、configureは通るもMakeでNG、最初のmerger.cはxe-kdoo(2005-09-21)を参考にして通すが、その次にlibrast.so:undefined reference to `libiconv_open’となって止まる。

おとなしく0.2.0を再度インストールするかな。

追記:環境変数LIBSに、-liconv を追加するとMakeも通ってインストールできたみたいだが、rast-register.rbではエラー

前の記事

ゲド戦記